Parameter Issues

Jul 2, 2015 at 7:06 AM
I am getting this error.

Warning:7/2/2015 2:57:01 AM: ID 1: Parameter Company invalid value 8300
7/2/2015 2:57:01 AM: ID 1: Parameter Company set to 8300 (Mutliselect, exclude)

SQL Server 2012 Standard Edition.

I want to set the dimension to slice the report for the company 8300. I have tried the following values and none of them work.
  1. [Company].[Company].[8300]
  2. [Company].[Company].&[8300]
  3. 8300
  4. [8300]
When I use [] they are striped out of the parameter according to the logfile. Do I need an escape character to stop it from striping out the brackets?
I need to know the syntax for the parameters when using a cube as the source. Also I have read different ways to setup the default parameters in the report. Which way should it be done.
Coordinator
Jul 2, 2015 at 6:09 PM
Hi gfarell

i made a new release to hanlde this case
https://busyreports.codeplex.com/releases/view/616070

i don't have SSAS reports just here to test it out, would be glad if you can report back if it worked. you will need an extra set of brackets around the parameters:
e.g.
[[Company].[Company].[8300]]
[[Company].[Company].&[8300]]

you can also select many:
[[Company].[Company].[8300],[Company].[Company].[8301]]
Jul 2, 2015 at 11:19 PM
Hi,

Thanks for the reply I really appreciate it.

I actually saw your hint on the the gui and tried the extra brackets.

How should I setup the parameters in the report? I don't want to use the defaults. I want to type in my own parameter value. What should I set the Available and Defualt values in the parameter? From query? No default?


Regards,
Garry Farrell

Jul 3, 2015 at 12:13 AM
Hi,

I now tested version 1.3. I got it to work but I had to modify the parameter string until it worked. I had to drop the opening [

This is what it should be.
[[Company].[Company Code].&[3200],[Company].[Company Code].&[8000]]
This is what I had to use.
[Company].[Company Code].&[3200],[Company].[Company Code].&[8000]]

Even when I wanted to use only one value then I had to add the ] at the end to get it to work. It is still looking for a list, which is fine, since I have set the parameter to allowed multiple selections.
[Company].[Company Code].&[3200]]

If you need the log let me know. I could see in the log that the last ] was missing.
Parameter CompanyCompanyCode set to [Company].[Company Code].&[3200 (Mutliselect)

Garry
Jul 3, 2015 at 7:30 AM
Hi,

A new feature that I would like. Can you add a scheduler? Even a shared scheduler would be nice so I can setup one schedule and link the reports to it.

Regards,
Garry
Coordinator
Jul 7, 2015 at 6:03 AM
Hi Garry

I fixed the bug with the opening [, thanks for reporting it.

It is very easy however to set up a schedule, with BusyReportsConsole.exe (look up the documentation). you can add a few in a .bat file and schedule this in windows scheduler. I would recommend however to integrate this in ETL process, so if the data load is late or failed, you don't have to restart your reports.

Cheers
Léo